Why Can’t I See My Favicon?

    March 23, 2007

Dear Kalena…

I have my own domain and I created a favicon. I did all I was supposed to do but still can’t see the ico. In Mozilla we can see it on our office computer, but on the two other computers we can’t see it on Explorer. I hope after 1.5 days of brain-wrecking trying….. you have the ground breaking answer for me. http://www.mohawkmotel.ca/favicon.ico

Thanks from Canada


Kalena’s Answer:

Dear Shirley

Don’t panic – I see it just fine in both Firefox and IE from here. What version of IE are you testing it on? I’m using IE 7. Have you bookmarked the site and refreshed the page? Try doing that on the computers where you can’t see it and also try dumping your browser cache, your temporary Internet files and your visited page history and then relaunch your browser. I’m betting this will solve the problem.

Meanwhile, you have a more pressing problem with the site. What on earth are you thinking keyword-stuffing the top and bottom of your home page with tiny text? You can’t tell me that text is there for humans to read. Aren’t you aware that such retro spam can earn you ranking suppression penalties on the search engines? And then you add insult to injury by stuffing (nearly) hidden links leading to some type of link farm all along the bottom of the page.

Are you not aware that these techniques go against Google’s published Webmaster Guidelines? It doesn’t look as though Google has caught it yet, but be ready for your rankings to plummet if they do. Tsk Tsk!