PSA: Update Firefox Immediately—Critical Vulnerability Being Exploited

A recent release of Mozilla Firefox has a vulnerability severe enough that even the Department of Homeland Security is telling everyone to update. According to Mozilla, “incorrect alias information in IonMonkey JIT compiler for setting array elements could lead to…