Quantcast

The Firefox Upgrade and Plugins Dance

Get the WebProNews Newsletter:


[ Business]

Mozilla released an update to the Firefox browser earlier this month which, the release notes say, provides improved stability, improved support for Mac OS X, fixes for several memory leaks and several security enhancements among other things.

Notwithstanding the security fixes, I’m not upgrading to this latest version 1.5.0.1 yet. The reason? If I do, some essential plugins (aka extensions) will stop working.

Every couple of days, Firefox pops up a dialog (the image you see here) reminding me that the new version is available. Every time it does, I click on the ‘later’ button as the dialog tells me some plugins won’t work. Clicking on ‘show list’ displays them – googlebar 0.9.15.07, SpellBound 0.7.3 and Mozilla Spellcheck Libraries 1.0.1.0 (the latter two in particular being essential to have, and have working).

There may be others but these are the ones on my system that Firefox says won’t work if I upgrade.

This situation is always a pain as it occurs with each Firefox update. If a plugin doesn’t work, this is Firefox’s advice in known issues:

If you find that your favorite Extension or Theme has not been updated to be compatible with this release of Firefox, write the author and encourage them to update it.

Right. So in the meantime, I’d have to do without their functionality.

This post isn’t really the rant it might seem to be. It’s just that I wish this dance between Mozilla and the developers of plugins would get more in sync.

So I’ll wait until the popup doesn’t tell me about things that won’t work.

Neville Hobson is the author of the popular NevilleHobson.com blog which focuses on business communication and technology.

Neville is currentlly the VP of New Marketing at Crayon. Visit Neville Hobson’s blog: NevilleHobson.com.

The Firefox Upgrade and Plugins Dance
Top Rated White Papers and Resources
  • http://www.teacupsandtutus.com/boutiquetutus.html Guest

    That is one of the major problems that I have with firefox.  The plugins periodically break, and often it is not really because they will not work, it is because the software marks them as incompatible.

  • Join for Access to Our Exclusive Web Tools
  • Sidebar Top
  • Sidebar Middle
  • Sign Up For The Free Newsletter
  • Sidebar Bottom